Server Requirements

  • Linux/Unix/Windows OS *
  • Apache Server 1.3 or higher
  • ModRewrite installed
  • PHP 5.2.4 (server module and system binary, as Apache module) or higher
    • suexec must be disabled
    • suPHP, suApache, Suhosin must be disabled
    • cURL support
    • register_globals off/off
    • safe_mode off/off
  • MySQL 5.0.3 or higher
  • GD Library 2 with FreeType support
  • Mail server (SendMail, Exim or other)
  • Cron

If you want to use Adobe Flash technologies for video sharing instead of Microsoft Media, you also need to have additional server software installed:

  • FFmpeg (http://ffmpeg.mplayerhq.hu)
  • Mplayer + Mencoder (http://www.mplayerhq.hu/design7/dload.html)
  • Flv2tool (http://www.inlet-media.de/flvtool2)
  • Libogg + Libvorbis (http://www.xiph.org/downloads)
  • LAME MP3 Encoder (http://lame.sourceforge.net)
* Note: SSH access details are required during every update, and could be requested during installs in rare cases.